
On Quality

1. Download the latest drivers for you gfx card.
2. In gfx card settings do following steps
    a) uncheck "application controlled/use application settings" whenever you see it
    b) push all sliders to the right (Quality)
3. Download Demomanager and MovieUnreal2002 (they should be in this .rar but ... ):
    http://moyd.mm1.cz/moviedemomanagerv1_1.rar
    http://moyd.mm1.cz//MovieUnreal2002.zip

    READ README.TXT AND INSTALL.TXT IN ORDER TO LEARN HOW TO WORK WITH
    THEM

    Do not forget to copy clearhud.ini to your System folder!
4. Back up your User.ini and MovieUnreal436.ini and copy my config to your System folder (either  
    OpenGL or D3D9 version, your pick).
    Note: Assault demos refuse to work with this User.ini, but you can always yours and just use
    CleanHUD or clearhud.ini to get rid of all on-screen info.
5. Now open MovieUnreal436.exe and do following changes:
    a) Output settings:
        - Video (AVI) -> choose -> uncompressed OR huffyuv
        - if fancy error message appears, select Shots (BMP) next time
    b) Create subdirectories - check
    c) Rendering:
        FPS: 30 (it's your call, choose whatever FPS you like, lately I've been using 50)
        Enable FPS changes: uncheck
        Start capturing immediately: uncheck
        Gamma correct output: uncheck if using OpenGL/check if using D3D
    d) Frame size: (also depends on what your monitor can handle)
        Width: 1280
        Height: 800
        These values gotta match FullscreenViewportX= and FullscreenViewportY=
        in your MovieUnreal436.ini (resolution in UT)
        Scaling: Super Sampling (useful only if while scaling down – don't really suggest to do that)
    e) Click OK
6. Now in UT get to Mod -> Demomanager -> Paths and set the path to your demos (for example
    C:\UnrealTournament\System\Demos\ )
7. Load a demo
8. You can use slomo command change the demo playback speed.
    slomo 1 = demo will run at normal speed
    slomo 0.5 = demo will run twice slower
    slomo 10 = demo will run ten times faster

    For watching a demo I don't recommend values higher than 2 (it's easy to miss a frag), but
    once you watch a thousand demos, you can easily work with slomo 5.
    Once you notice a frag you want to use, press Pause key, open the console and type curtime.
    Curtime is time in seconds from the beginning of demo and it's pretty useful, because standard
    UT clock is inaccurate and while using higher slomo (use slomo 10-15 if you want to rely on
    UT clock, higher values will fuck it up). Note the curtime somewhere (I prefer to change 
    the demo name, for example: agony_breach_740-ripperairhs.dem
    (map_opponent_curtime-fragtype).
9. Now lets assume you have a list of demos marked with curtimes. Open MU -> open the console 
    and type "exec clearhud.ini" -> load a demo -> get to desired curtime (I like using high slomo 
    like 100 for a second (Note: MovieDemomanager1.1 handles very high slomo, but in my

http://wizii.wz.cz/moviedemomanagerv1_1.rar
http://wizii.wz.cz/MovieUnreal2002.zip


    experience not every DemoManager can do that – as in they can't handle slomo higher than
    50 or something), then slomo 1, curtime to see where I am, high slomo again etc etc till I  
    get to the frag position). Also you may notice that there are scorch marks on textures created 
    by rocket/combo explosions. That's caused by Decals = True. In order to prevent them from 
    appearing you need to let UT run on normal speed for a while (circa 30-50 secs). Thus if your 
    curtime is 660, stop fast-forwarding your demo @ curtime 600-630. Or simply disable Decals.
10. When you can recognize the frag scene, press F12. UT will slow down A LOT but that's 
     normal (OpenGL is MUCH faster than D3D9). Record whole scene + few extra second and
     press F12 again to stop recording.
11. Import your footage to Vegas (if it's a sequence of BMP files: select the first BMP file,
      wait a bit, check Open still image sequence and click OK)
12. Press Alt+Enter and set the Project Properties:
      Width: same as in MU
      Height: same as in MU
      Frame rate: same as in MU
      Field order: none
      Pixel aspect ratio: 1,0000 (Square)
      Full-resolution rendering quality: Best
      You can keep the rest on its default settings.
13. To have 720p (1280x720 progressive) you will probably need to crop your footage (only if your
      footage was recorded at 1280x800 and higher) AND change the Project Properties of course,
      because you want to have 1280x720 as output resolution, not 1280x800.
      Drag your footage onto the timeline -> right click on it -> Video event pan/crop.
      A cute window with big F letter and a preview of your avi should appear. On the left side you
      should see few icons (or somewhere else in that window). Find "Lock aspect ratio" and disable
      it. Find "Size about center" and enable it. You should also see Position: Width/Height. Click on
      height and set 720. Find Source: Stretch to fill frame (still in this dialog window) and set it
      to "Yes". That's it. At this point your avi should be cropped nicely.
14. Those who don't have AE or just don't know it "well" (for example: don't know how to create
      a composition) can skip this step. I'm gonna say few words about color correction and
      motion blur. There's much more ways to do that, I'm just gonna describe this universal one
      and unless you know more on this topic and have your way to do that you can use this one:
      - Open AE, load your footage, create new comp, drag footage onto the timeline
      - Apply Color correction -> levels
        - Basically you always want "the hill" to fill the whole space (from left slider to the right one),
          but that rarely happens. Click and hold the left slider and push it closer to the bottom of
          the hill. Do the same with the right slider.
      - Apply Color correction -> curves and create this S-shape which should give you nice contrast
      - You may add Color correction -> Hue/Saturation and boost saturation just a little bit to get
         better looking colors (max 20% or something, if you boost it more it will not look good)
      - Now duplicate the layer and in the top layer add Color correction -> brightness and
         boost it up. Do the same for Saturation - boost it up a lot (I know I just said not to do
         that, trust me)
      - Change the transfer mode for the top layer to Lighten and lower the opacity to 30 or 40%
      Just a quick note - some ppl say you always wanna have balanced colors, no really dark
      scenes etc. .. but think about it - some scenes are really meant to be dark or just for example
      green only. And no other colors. Why would you wanna add another colors when it's meant
      to be green? (for example sniper window on arean (dunno which base though)). It's
      always fine to experiment and make stuff look cool, but that doesn't mean you have to
      change everything you can.

     You always need to key-frame several values (levels, curves, saturation etc)
     in order to achieve nicely looking scene, because it changes every second.



     Adding motion blur:
     - Get RE:Vision Reel Smart Motion Blur Rro
     - Once you are done with color correction, select both layers and precompose them.
     - Apply RE:Vision Plug-ins -> RSMB Pro. You may leave all default values except for
       Main_BG: Blur amt: 0,20
       Main_BG: Sensitivity: 75,00
       Of course you can mess with them and use other values.
     - Don't forget to mask out the kill messages!
     - Render
15. Because I'm focusing on quality, I will skip this step - creating your movie
16. Select your movie and click on File -> Render as
     - File type: avi
     - Template: default (uncompressed) and click on Custom
     - Click on Video:
       - Include video: check
       - Frame size: Custom frame size and input the resolution you were using .. in our case it's
         either 1280x800 or 1280x720 (Step 13)
       - Frame rate: 30
       - Field order: none
       - Pixel aspect ratio: 1
       - Video format: uncompressed OR huffyuv
       - Interleave every (seconds): uncheck
       - Render alpha channel: uncheck
       - Create an OpenDML compatible file: check
     - Click on Audio:
       - Include audio: uncheck
     - Click on OK, click on Save
17. Select your video again and click on File -> Render as but this time select file type: wav and
     render it.
18. The XviD compression:
      Now you need to install and open up VirtualDub. You also should take this time to install
      the XviD 1.1.3 files as well, because you will be using these for compression purposes.
     - Open VirtualDub and click File > Open video file...  Find your uncompressed .avi file that
       you just rendered with Sony Vegas and open it.
     - Click on Video > Compression.  Select XviD MPEG-4 Codec from the window and click OK.
       Open XviD screenshots folder and make sure your settings are same. Before you compress 
       your movie I have to tell you, that there is nothing like unique XviD settings. For each movie
       you have to create new settings, or at least change them a bit (depends on resolution, fps,
       scenes, textures, details, effects, motion, depth, blur, colours, ...). The settings I use should
       give you decent results if you work with HD 720p footage, BUT the filesize will most likely
       go skyhigh. You really do need to do shitloads of test.
     - Click on Audio > Wav Audio and load your uncompressed .wav. Then click on Full Processing
       Mode. Click Audio > Compression. Select MPEG-Layer 3 and a reasonable kbit value and click
       OK.
     - Now pay your attention. In XviD dialog, select Encoding type: Twopass - 1st pass, click on
       More, check Discard first pass, uncheck Full quality first pass, click OK, once again,
       File > Save as AVI > OK. XviD will do the first pass (basically it will gather information about
       your video file so it can distribute bitrate better during the second pass). Once this is done,
       click Video > Compression > XviD > Encoding type: Twopass - 2nd pass and click OK and
       File > Save as AVI > OK. Your compressed file will probably be extremely big due to these
       setting which were not designed for your movie. If so, select Twopass - 2nd pass and click
       on More -> Quantization and change Max-P to 5 and Max-B to 7. If your file is still too big,
       set even higher values for Max-P and Max-B again.
     - This is very boring process and it takes some time (days, weeks, months) to find nice settings 



       and that's why a lot of movie makers don't provide an xvid version of their movies. Simply 
       because they don't know what settings they should use/change etc.

    VirtualDub will begin compressing your movie. Once the process is complete, the finished
    product is your compressed movie. You can delete the very large uncompressed .avi (after you 
    check out your final movie for errors etc!) file from Sony Vegas now and view your work of art.

19. The x264 compression:
     - Download and install MeGui and AviSynth (.NET Framework 2 is needed)
     - Create a file called output.avs for example (AVS script folder) and put there following lines:

AVISource("nameOfYourFile.avi")
          ConvertToYV12()

     - Open MeGUI and press Ctrl + U for updates.
     - Click on File -> Import presets and select HQ_presets..zip from the MeGui Preset folder
     - Once you have latest versions of all files, load your AviSynth script (that output.avs you 
       created before). A preview window will pop up, but
       we don't need to work with it, so feel free to close it. 

     - Encoder settings: Select x264: HQ-720p
     - Click on Enqueue
     - Audio:
       - Audio Input: load your uncompressed .wav file
       - Audio Output: just some filename
       - Codec: AAC – FAAC
       - Extension: M4A
       - Delay: 0
       - Config > Set some reasonable bitrate
     - Click on Enqueue
     - Click on Workers > Create new worker
     - Click on Queue > Start. MeGUI will now encode your .avi and .wav to separated .mp4 files 
       (video .mp4 file will have same filename as your .avs file). Don't be surprised by _VERY_
        low encoding rate. Encoding x264 is CPU-killer and my settings are insane. Anyway, once
       the encoding of both files is done, click on Tools > Muxer > MP4 Muxer, load your encoded
       video .mp4 file (Video input) and audio .m4a file (Audio input), change the final filename
       (Muxed output), click Queue and Start. Muxing should take few seconds


